O seu servidor funciona com a versão 4.4.4 do PHP, mas o WordPress 3.9.2 necessita pelo menos da versão 5.2.4.